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Abstract

For most Miocene taxa, primate fossil evidence consists of broken cranial bones, teeth, 

and jaws. Studying these fossils is difficult due to the damage and distortion during geological 

stress. During fossilization the soft tissue preservation of these specimens is usually nonexistent. 

Homunculus patagonicus is an unusual primate from the Miocene epoch (~17 million years old) of 

extreme southern Argentina. The first associated cranium and mandible of this species will allow 

the most complete reconstruction of the adaptations of any early platyrrhine. To reconstruct the diet 

of such extinct mammals, the jaws, skull and muscles of mastication provide insight into how food 

properties influence skull morphology over evolutionary time (Perry, 2018). This project allows the 

use of comparative anatomy to learn how H. patagonicus lived, and its relationship to its environment 

through an examination of dietary adaptations.

Using extant analogs, correlations can be made between muscle and bone dimensions 

providing informed inferences about feeding behaviors in fossils. Inferences can be validated because, 

“Diet and mastication are closely tied to hard anatomy” (Perry, 2008). Thus, access to data from living 

analogs makes reconstructions of mastication especially justifiable for early primates (Perry, 2008). 

This data can be then used to recreate the magnitude and orientation of the force produced by the 

adductor muscles. These variables can be used to better understand the properties of foods and how 

they relate to food processing anatomy and behavior (Perry et al. 2011).   

This project leverages digital visualization techniques to provide an interactive application 

using the digital fossil reconstruction of Homunculus patagonicus. The reconstruction of the skull 

and jaw adductor muscles are implemented through an interactive iOS application in addition to the 

original CT fossil data, extant distribution maps, and primate phylogeny. This application will not 

only provide researchers, students and the general public a learning resource but will also contribute 

to the fields of virtual paleontology, biocommunication and plastic surgery, especially facial 

reconstruction.
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Introduction

Over the past century, the Santa Cruz Formation of costal Argentina has yielded a 

remarkable collection of primate fossils including Homunculus patagonicus, a primitive platyrrhine 

monkey (Kay et al. 2012). For most Miocene taxa, fossil evidence consists of broken cranial bones, 

teeth, and jaws. Homunculus patagonicus is an unusual primate from the Miocene epoch (~17 million 

years old) of extreme southern Argentina. It is well known from much of the skeleton and from a 

few crania; specifically, one unpublished specimen that forms the focus of this project. The first 

associated cranium and mandible of this species will allow the most complete reconstruction of the 

adaptations of any early platyrrhine. To reconstruct the diet of such extinct mammals, the jaws, skull 

and muscles of mastication provide insight into how food properties influence skull morphology over 

evolutionary time (Perry, 2018). This project allows the use of comparative anatomy to learn how 

Homunculus patagonicus lived, and its relationship to its environment through an examination of 

dietary adaptations.  

1. Early Platyrrhine Primates 

Figure 1. Phylogenetic tree of Platyrrhini (New World Monkey) Lineage
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New World monkeys, known as platyrrhines, rapidly diversified in South America during 

the Miocene Period, 24-5 million years ago, and their fossil record documents the earliest appearance 

of modern platyrrhine lineages. Today, the southern edge of the geographic range of platyrrhine 

primates is at latitude 29° S. However, in the Early Miocene, a time interval frequently referred to as 

the Mid-Miocene Climatic Optimum, several medium sized platyrrhines lived much further south 

in Patagonian Argentina (Kay et al. 2012, p.307). Towards the end of the Early Miocene at 18-16 

Ma, platyrrhines reached their southern latitudinal extreme at 51° (Kay et al. 2012).  Homunculus 

patagonicus was the first known Miocene platyrrhine, described by Florentino Ameghino in 1891. 

The specimen was recovered at the coastal Santa Cruz Formation (51° 38’ south) where since then 

a number of stem platyrrhine fossils belonging to the family Homunculidae have been recovered. 

The extraordinary completeness of the cranial specimens allows us an exceptional opportunity 

to reconstruct aspects of cranial functional morphology that are unavailable for other Tertiary 

platyrrhines (Perry et al 2010) (fig 2).

Figure 2. Homunculus patagonicus fossil specimen of cranium and mandible (MPM-PV 17453).

2. Masticatory Anatomy 

Jaw adductor muscles of primates work together to achieve food breakdown (Perry et 

al. 2011). This masticatory anatomy consists of the temporalis group, masseter group and medial 
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pterygoid. The temporalis group consists of three portions, the superficial, deep, and zygomatic 

temporalis. The masseter group is made up of the superficial masseter and deep masseter as well as 

the zygomatico-mandibularis. The study of masticatory anatomy including the jaw adductors allows 

for important inferences to be made about diet, body form and function, and evolution (Perry, 2008). 

The adductors work in a complex system to perform a single action that can be “used as signals for 

dietary adaptation” (Perry et al. 2011). 

Using extant analogs, correlations can be made between muscle and bone dimensions 

providing informed inferences about feeding behaviors in fossils. Inferences can be validated 

because, “Diet and mastication are closely tied to hard anatomy” (Perry, 2008). Thus, access to data 

from living analogs makes reconstructions of mastication especially justifiable for early primates 

(Perry, 2008). This data can be then used to recreate the magnitude and orientation of the force 

produced by the adductor muscles. These variables can be used to better understand the properties of 

foods and how they relate to food processing anatomy and behavior (Perry et al. 2011).  

2.1 Homunculus patagonicus Dentition 

The study of Homunculus patagonicus dentition and diet is especially important because of 

the observations of specimens’ extremely heavy tooth wear. The tooth wear patterns can indicate the 

environment this genus inhabited. Observation of many museum specimens of extant platyrrhines 

leaves the impression that tooth wear rates are greater in primate populations that inhabit dry forests 

or habitats with long seasonal dry intervals than in populations that inhabit humid forests (Kay et al. 

2012). Homunculus could indicate that the environments where this genus occurred had deciduous 

forests with low rainfall and considerable seasonal variation (Kay et al. 2012). It also remains a 

possibility that exogenous dust particles would have played a significant role in tooth wear, given the 

predominantly tuffaceous nature of the sediments where Homunculus is found (Kay et al. 2012). 

3. Digital Paleontology 

With the continued advancements of technology, fossil specimens can be CT-scanned and 

digitally reconstructed. Although this has yet to be a completely adopted process, it has a promising 

future to protect fragile fossil specimens and data. The digital reconstruction process can allow 

fragmented fossil data from multiple specimens of the same species to be used to fill in missing 

anatomy and provide a more complete, composite member of that species. Although this process 

might mask variation between individuals, it is of use for understanding overall biomechanics in the 
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species. 

4. Augmented Reality in Education 

Augmented reality (AR) is a technology that integrates virtual elements with the user’s 

immediate surroundings so that they can interact with them in real time (Monkman and Kushniruk 

2015). This superimposition of virtual objects into physical space allows for an interactive learning 

environment. Research, conducted by Albrecht in 2013, suggests that the application of AR led to 

significantly higher knowledge gain in comparison with textbooks. Allowing users to interact with 

3D models from different points of view, including through AR, can improve their spatial awareness, 

memory of the subject, and enable personalized, self-directed learning (Küçük et al. 2016).  

The implementation of AR to teach primate anatomy will provide an innovative approach 

to presenting visual anatomical information clearly and interactively. As the first of its kind, the 

application will assist in learning anatomical detail while retaining 3D relationships in real time than 

cannot be replicated by current resources. The accessibility provided by an AR application allows 

users to directly compare specimens, enabling the assessment of size and diet, which are critical in 

fossil primate analysis. The user will have the ability to bring the digital specimen to the field, and 

back to the lab or classroom, making the application fully adaptable to each user’s unique goals and 

research. Without the app, the user would need to either handle the fossil directly or make a replica of 

the fossil – which would have the potential of damaging it from the act of handling.  

5. Objectives 

The goal of this project is to develop an interactive augmented reality 3D reconstruction 

iOS application of the skull and the chewing muscles of Homunculus patagonicus using soft tissue 

indices. Current teaching materials rely on simplistic line diagrams and photographs which do not 

allow for detail of bony landmarks and delicate muscle fiber orientations. Digital resources such as 

three dimensional (3D) anatomical learning applications are presently limited to human and canine 

anatomy. By using augmented reality, the user will understand more fully the muscles of mastication 

and their spatial relationships in Homunculus patagonicus through an interactive 3D environment. 

As an application, accessibility will allow users in the field to compare newly discovered fossils 

to the model, as well as the anatomy of living specimens. An application allows content to be 

viewed anywhere in the world with or without an internet connection once the application has been 

downloaded. The features of the application will allow for control of individual muscle visibility, 
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anatomical annotations, and camera functions such as zoom, pan and rotate. Learning and reviewing 

the anatomy in this original way will improve anatomical knowledge including the cranial landmarks 

which serve as sites of muscle attachment. The specific goals include the creation of: 

A digital 3D model of a reconstructed cranium and mandible of Homunculus patagonicus 

    from CT data of MPM-PV 17453. 

Digital 3D jaw adductor muscle models, origins and insertions based on extant analogs. 

A fully interactive iOS application to display models and animation.  

A digital 3D facial approximation using ZBrush and forensic facial reconstructing 

    techniques. 

A reproducible workflow documenting the steps from CT data acquisition, digital 

    reconstruction, animation of the muscles, and finally, creation of the application. 

6. Audience 

The primary audience for this application is scientific colleagues, PhD, graduate and 

undergraduate students conducting research on primatology and mammalian evolutionary biology. 

The secondary audience is a broader interested public. The tertiary audience for this application is 

clinicians for use in comparative approaches for presurgical planning. 

7. Significance of the Study 

This project leverages digital 3D reconstruction of Homunculus patagonicus, to bring ancient 

primate chewing muscles and dynamics back to life, contributing to the study of and education about 

primate evolutionary lineages. Emerging technology using augmented reality 3D visualizations has 

provided a novel approach to anatomical education which will continue to be pivotal to the profession 

of visual biocommunication. This application and methods will serve as a model to aid in the future 

reconstructions of skulls, ranging from those of fossils to patients with facial injuries. Our profession 

will be able to better serve patients requiring reconstruction and custom implant services by using 

this new model of reconstruction.
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Materials and Methods

1. Data Acquisition and Processing  

A micro-CT scan of a fossil specimen of Homunculus patagonicus was provided by the 

Center for Functional Anatomy and Evolution (FAE), at the Johns Hopkins University School of 

Medicine. Three-dimensional data of the specimen (MPM-PV 17453) were obtained from computed 

tomography using a SkyScan 1173 Micro CT scanner referred to as the Y-CET scanner operated by 

the company YPF located in Argentina. The scans were made for Susana Bargo of the Museo de La 

Plata, Argentina. A tiff stack of images resulted from the scan of the cranium. The mandible was also 

scanned using the same scanner and basic scan protocol, resulting in a separate tiff stack. 

1.1 Segmenting and Contour Mesh Creation using Dragonfly ORS  

Dragonfly 4.1 software (Object Research Systems) was used to view and process the CT data. 

The images were imported by choosing the tiff stack data set (File > Import Image Files > Select all 

images in stack). The Reverse sort option box is checked to match the reference photos provided of 

the fossil specimen. The data were then cropped to avoid including the scanned scale bars. Once the 

images were loaded, orthogonal view was selected to show the fossil in four orientations. Window 

leveling was used to adjust the ranges of the histogram to remove surrounding air and matrix. The 

images can also be segmented using a selection process but was not necessary for this fossil. A 

contour mesh was created using Generate Contour Mesh (select RedOffset2_rec0945 data set > 

Generate Contour Mesh). Once the mesh was created it was exported. (select Contour Mesh of 

RedOffset2_rec0945 data set > Export > Mesh to File > Save as type >WaveFront (*.obj) (fig 3). 

The final model was exported as an OBJ file. The mandible was segmented in a similar manner. 

Figure 3. Screen shots of the (A) Contour Mesh of the cranium (B) pre mesh, within Dragonfly software. Not all text 
intended to be read.

A B
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1.2 Sediment Removal using Cinema 4D 

Sediment from the segmented CT data was creating millions of non-manifold polygons inside 

the cranium, orbits and nasal cavities. To optimize the model, the sediment needed to be selected and 

deleted. Cinema 4D R20 (C4D) software was used to view and process the segmented data further. 

With the model opened in C4D, polygon mode was selected (Tools > Modes > Polygon). Using the 

Model layout interface, portions that were to remain unedited were selected with the lasso selection 

tool and hidden using Hide Selected (Select > Hide Selected) (fig 4). Once the inside of the cranium 

was visible, unwanted polygons were selected with the live selection tool (Select > Live Selection). 

To grow the selection and ensure that the outside bone structure remained intact Grow Selection 

(Select > Grow Selection, or shortcut U~Y) was used repeatedly until a desirable selection was 

large enough and then deleted. If any sediment was free floating and not connected to the outside 

structures Select Connected (Select > Select Connected, or shortcut U~W) was used to select and 

delete polygons. During the process of deleting polygons the model was checked regularly using 

Unhide All (Select > Unhide All). This ensured no polygons on the outside of the skull were being 

accidentally deleted.  

Figure 4. C4D Sediment Removal (A) Lasso selection (B) Hide selection. Not all text intended to be read. 
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As portions of the sediment were deleted small connections to the cranium were closed from 

the outside of the model, also referred to as Patching from Normals. After creating an unwanted 

opening, Close Polygon Hole was used to automatically close an entire hole. (Mesh > Create Tools 

> Close Polygon Hole, or shortcut M~D). In some cases, the Polygon Pen was used to create new 

custom polygons before using Close Polygon Hole (Mesh > Create Tools > Polygon Pen, or shortcut 

M~E). After the holes were closed the mesh was checked to ensure there were no non-manifolds 

edges or holes (Mesh > Commands > Modeling Settings > Mesh Checking). Larger polygons 

were Triangulated to help with convex forms (Mesh > Commands > Triangulate). The model 

was optimized before exporting to remove any unused points (Mesh > Commands > Optimize, or 

shortcut U~O). The model was then exported as a Wavefront OBJ file to be imported into ZBrush 

(File > Export > Wavefront OBJ (* .obj)). 

2 Virtual Skull Restoration using ZBrush 

Homunculus patagonicus fossil reconstruction was done using a variety of techniques in 

ZBrush 2019, a polygonal based 3D modeling software. Because the fossil was highly fragmented and 

distorted it was reconstructed with the intention of recreating the anatomy of an average member of 

the species. As many data as possible were preserved in addition to using artistic license to create an 

undamaged reconstruction of Homunculus patagonicus. As seen in Figure 5, large fracture patterns 

were used as guides to move segments back into place like putting together a puzzle. 

Figure 5. Screenshots of fossil .OBJ oriented in ZBrush (A) Superior view (B) lateral view with mandible orientation 
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2.1 Model References 

A 3D OBJ specimen of Pithecia pithecia, as well as CT scans of other Homunculus 

patagonicus specimens, were provided as references (fig 6). The P. pithecia digital reference was 

useful for comparison while modeling in ZBrush. The references provided a better understanding 

of an overall shape and alignment for mandible and cranium articulation. Another Homunculus 

patagonicus scan was used to help fill in missing pieces on the original CT scan, MPM-PV 3502. This 

specimen had one complete orbit and zygomatic arch that was used in the reconstruction of the main 

specimen. A third Homunculus patagonicus specimen was used for visual comparison, MPM-PV 

3501. 

Photographs of MPM-PV 17453 as well as other specimens were also provided by the 

Johns Hopkins Center for Functional Anatomy and Evolution. The specimens were all fragmented, 

damaged or distorted in some way. However, by comparing multiple images and models together, 

educated decisions could be made during the reconstruction.  

Figure 6. Reference Model Pithecia pithecia from the National Museum of Natural History, Washington, DC, USA 

2.2 Reorientation of Fragments 

Once the .OBJ model was imported into ZBrush and reoriented, the bone fragments were 

moved back into place by locking certain areas with the MaskPen (Control+draw). The grayed-out 

areas do not move while the portions intended to be moved can be adjusted to follow bony landmarks 
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(fig 7). Some of these movements were slight but helped correct the fragmentation. The entire 

reconstruction was approached by creating an imaginary midline down the center of the skull and 

studying both left and right sides. Some portions of the cranium were more intact than others. This 

made the reconstruction easier by duplicating preserved areas and mirroring them to missing portions 

on the opposite side.  

Since the right side of the cranium was so distorted the left side was chosen to be reflected 

specifically on the cranium portion. The skull was split down the center while in a superior view 

using the SelectRect tool and then dragging down to create a rectangle. To make sure the preferred 

selection stays visible the rectangle will turn green, red will hide the selection in the rectangle 

(Control+Shift+Drag). The hidden portion was deleted by pressing Del Hidden (Tools > Geometry 

> Modify Topology, click Del Hidden). Because the delete hidden tool was used so much throughout 

the reconstruction process it was added to the interface by creating a custom interface. The skull was 

then duplicated and mirrored (Deformation > Mirror). This mirrored portion is then fit into place 

using the original CT data as a guide to align the new half. 

Figure 7. ZBrush screenshot of masked section of specimen following fracture pattern 

The original specimen’s zygomatic arches were not preserved during fossilization. To 

continue using as many data as possible zygomatic arches came from MPM-PV 3502 and were fit 

into place using the MoveTopological tool just at the connection points to the cranium. By observing 
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the original specimen and the bony landmarks, smooth transitions were made to the new zygomatic 

arches and confirmed accurate by Dr. Perry. The arches were not merged to the skull until a later time 

to make editing behind them easier. The orbits and rostrum were also taken from the same MPM-PV 

3502 and merged later.  

The pterygoid process on the left side of the skull was completely collapsed in the original 

data set. The right side however was fully intact with only slight fragmentation. The right pterygoid 

process was duplicated and manipulated before mirroring it to the left side. The largest fragmented 

portion was isolated using the SelectLasso tool followed by Delete Hidden to remove unwanted data. 

This allowed easy realignment using the MoveTranspose tool to slide the fragmented portion into the 

correct orientation. Following the fragmentation and missing anatomy it was moved back into place 

with confidence. Throughout the reconstruction, to ensure accuracy of placement, it was made sure 

that no bone was overlapping in any way. After merging the portion of bone that was isolated back 

into the original pterygoid portion on the cranium it was DynaMeshed and then duplicated for the 

left side. The duplicate was mirrored for the left side and reoriented using bony landmarks using the 

MoveTranspose tool. 

2.3 Recreating Missing Anatomy 

To recreate missing anatomy portions were taken from MPM-PV 3502 CT data. This 

included the nasal bridge, orbit and zygomatic arch (fig 8). Once the data were moved in to place the 

orbit and zygomatic arch, data were duplicated and mirrored for the other half of the cranium. To 

fill in the small holes and cracks that resulted from fragmentation throughout the cranium a sphere 

was appended (Tool> Append > Sphere3D). Once appended the sphere was manipulated to form 

the shape of the cranium with the Move Topological tool (Brush > Move Topological). By holding 

Option on the keyboard, the selection moves in a linear path, allowing for easier formation of the 

cranium. The transparency tool allows visibility through the structures to help ensure the sphere 

overlapped in the correct places (fig 9). The geometry of the sphere was re-meshed using DynaMesh 

multiple times during this process (Tools > Geometry > DynaMesh). Once this sphere was shaped 

like the fossil cranium and checked by Dr. Perry for accuracy, it was merged with all the other 

subtools to create one unified structure (Merge > MergeVisible).  
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Figure 8. Image of MPM-PV 3502 .OBJ. Red areas represent anatomy taken to complete MPM-PV 17453 reconstruction.

 

Figure 9. (A) ZBrush screenshot of missing anatomy being reconstructed using appended sphere. (B) transparency tool 
allows visibility through structures to ensure as much data as possible is saved.

2.4 Mesh Integrity using Blender 

The previous sediment in the skull had created holes in the model causing complications 

in ZBrush functions. Attempts to check the mesh integrity and fix the issues in ZBrush were not 

successful (Geometry > MeshIntegrity > Check Mesh > Fix Mesh). The workaround for this issue 

was to export the merged model as an .OBJ using 3DPrintHub (Zplugin > 3D PrintHub> Export 

to OBJ). The model was then imported into Blender (File > Import > OBJ). Once imported, the 

Modeling tab was selected, and the entire skull was selected by pressing A on the keyboard. While 



13

in the Modeling tab, the mesh was cleaned up by using Merge By Distance to merge vertices based 

on their proximity (Mesh > Clean Up> Merge By Distance) (fig 10A). With the model selected, 

the Merge Distance can be adjusted by typing, or scrolling, to an appropriate number. For the skull 

it was 0.0805m(fig 10B). This merged everything overlapping and removed non-manifold edges 

resulting in a clean and hollow model. The model was exported from Blender and brought back into 

ZBrush (File > Export > OBJ). DynaMesh was then used to re-mesh the skull. 

Figure 10. Merge vertices by Distance in Blender. Not all text intended to be read.

2.5 Aligning Dentition and Mandible Reconstruction  

The mandible was aligned using three principles. First, alignment of the dentition was the 

most important to align; this was achieved using the MoveTranspose tool. The first priority was to 

avoid overlap of the teeth and/or teeth and bones. Second, the condyles needed to be in relatively the 

same location in both glenoid fossae. A small space was left to account for an articular disc for which 

the thickness is unknown and can only be estimated. The third priority was the symphysis continuity; 

that is, the bony contacts at the mandibular symphysis were not permitted to overlap and any gap 

between the two halves of the mandible was minimized. Both halves of the mandible had symphyseal 
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bone present, but neither half was complete at the symphysis. Once in an accurate position and 

confirmed by Dr. Perry, the reconstruction of the mandible took place. 

The left mandible was fragmented in multiple areas however, the right mandible was almost 

fully intact. To fill the gaps in the left mandible, the right mandible was duplicated and mirrored 

(Deformation > Mirror). It was aligned and oriented as close as possible to the left mandible. 

Using the SelectLasso tool only the data needed to fill in the missing or fragmented portions of the 

coronoid process, mandibular angle and inferior portion of the body of the mandible were kept. Using 

the Transparency tool (Activate Edit Opacity) the mirrored portion was manipulated to fit the bony 

landmarks of the left mandible. The transparency tool allows visibility through the two subtools to 

eliminate any extra polygons and a seamless overlap (fig 11). As many data as possible of the left 

mandible are preserved. 

Figure 11. Visibility through mandible subtool using the Transparency tool.  

The fragments of the coronoid process were removed from the left mandible using Live 

Boolean and an appended cube subtool (Append > Cube 3D). The cube was adjusted to overlap 

the structures that were to be subtracted from the left mandible using Make Boolean Mesh (After 

turning on Live Boolean > Tool > Boolean > Make Boolean Mesh). The subtracted left mandible 

was appended as a new subtool, the coronoid process of the right mandible was then aligned and 
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adjusted using Move Topological to match the bony landmarks of the remaining left mandible. This 

process was repeated for the other missing portions of anatomy. All of the subtools were merged 

together and remeshed using DynaMesh (Tools > Geometry > DynaMesh > DynaMesh). The 

smooth tool was then used to smooth the joined portions (fig 12) (Shift + Draw). 

The incisor on the left mandible had been broken off the fossil. To replace this the right 

mandible was duplicated and mirrored. It was fit into place to fill the missing tooth. To join the left 

and right side of the mandible near the symphysis the portion of the mirrored right mandible and 

replacement tooth was used to fill in the missing portion. It was moved into place using the Move 

Topological brush. After the gaps were filled, everything was MergedDown and DynaMeshed to 

re-mesh the entire mandible as a whole piece. Any rough edges were smoothed by holding Shift and 

clicking the cursor over the surface.  

Figure 12. Mandible fossil before reconstruction: (A) left lateral view (B) left medial view 
Mandible fossil after reconstruction: (C) left lateral view (D) left medial view. 

2.6 Scaling Reconstructed Model 

The model was scaled referencing photographs of a 10 cm scale placed next to the original 

fossil specimen. The specimen from the front of the upper canine to the back of the nuchal crest 

measured approximately 8cm. ZBrush is not based on mathematical points, so a cube measuring 8 
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cm was created in C4D. This cube was imported into ZBrush and appended into the Subtools. Using 

the ScaleTranspose tool the skull was scaled up to the accurate size (fig 13). This ensured accurate 

measurements for the reconstructed muscles. 

Figure 13. Scaling model using 8cm cube imported from C4D.

3 Dissection of Muscles of Mastication on Extant Primate Model 

Extant primate analogs were used to estimate the dimensions of the muscles of mastication. 

This process is important for richer inferences about Homunculus patagonicus lived and its 

relationship to its environment, particularly dietary adaptations. The data used to estimate muscle 

dimensions for Homunculus came from an extant dataset of South American monkeys (Hartstone-

Rose et al., 2018). Because no soft tissue is preserved in the fossil, it was necessary to use osteological 

proxies of muscle dimensions to make the muscle volume estimates. These osteological correlates 

consist of composite measurements including muscle attachment areas and distances between points 

of origin and insertion (see Perry, 2018). The osteological proxy measurements were taken by Dr. 

Perry on the surface model of the Homunculus skull specimen and the resulting values were plugged 

into prediction equations from the extant sample of platyrrhines. The predictions of muscle volume 

were adjusted for logarithm detransformation bias (see Perry et al., 2018). When two predictions for a 

single muscle were made, these were averaged to produce the value for muscle reconstruction.

As a guide to recreating the chewing muscles of Homunculus, I performed a dissection of the 
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chewing muscles of a platyrrhine primate. The dissection was completed at the Johns Hopkins Center 

for Functional Anatomy and Evolution under the guidance of Dr. Perry. The dissection was conducted 

on a fresh, frozen Golden Lion Tamarin (Leontopithecus rosalia) specimen. Both sides of the cranium 

were dissected, one half at a time. First, a midline incision dorsal to rostral was made with a #3 

scalpel equipped with a #15 blade. Once at the rostrum, a circumferential incision around the snout 

was made. The medial incision was continued on the ventral portion of the mandible to the neck. The 

skin was then reflected inferiorly to superiorly and anteriorly to posteriorly. The conjunctiva of the 

eyes were cut to remove the skin, and an incision was also made to disconnect the skin flap from the 

external auditory meatus. Once the skin flap was dissected, the muscles of mastication were exposed. 

The first muscle group dissected of the jaw adductors was the masseter. From superficial 

to deep they are superficial masseter, deep masseter, and zygomatico-mandibularis. The superficial 

masseter was approached inferiorly from the inferior edge of the mandible to zygomatic arch 

superiorly. The deep masseter had a white fasial layer on its superficial surface that thins as it runs 

superiorly, allowing differentiation of the deep masseter from superficial masseter. The deep masseter 

was removed superiorly from the inferior edge of the zygomatic arch and followed inferiorly to the 

ramus of the mandible. Lastly, the zygomatico-mandibularis was removed inferiorly to superiorly 

where it was removed from the inferior edge of the zygomatic arch.  

The second masticatory muscle group dissected were the temporalis muscles. The first 

muscle dissected was the superficial temporalis muscle which was approached superiorly to inferiorly. 

The superficial temporalis originates mainly from the overlying temporal fascia, but also from 

adjacent bone in some places. It inserts on the temporal tendon which itself is attached along the 

anterior edge of the coronoid process. The second muscle, the zygomatic temporalis, was approached 

inferiorly to superiorly following the tendon running along the coronoid process superiorly from the 

body of the mandible. The zygomatic temporalis originates from the dorsal and the medial side of the 

zygomatic arch. The deep temporalis muscle was dissected last, from superior to inferior. 

The last muscle group dissected were the medial pterygoid muscles. The jaw of the specimen 

was cut using a bone saw through the mandibular symphysis. This allowed access to observe the 

muscle insertion on the medial aspect of the angle of the mandible. The medial pterygoid was 

dissected from the mandible as well as the from the medial and lateral pterygoid plate. 

Photographs were taken during the dissection of each step of the muscle removal process. 
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Each muscle was individually weighed, wrapped in a paper towel in the same orientation it was 

removed from and soaked with preserving fluid. Each muscle was then placed in a plastic bag labeled 

with the respective muscle and orientation. Muscle were stored for later processing to obtain fiber 

length measurements (see protocol in Perry et al., 2011a).

3.1 Muscle Maps 

Muscle maps were provided by Dr. Perry and verified by me based on my dissection of the 

extant platyrrhine specimen to ensure accurate placement of muscle origins and insertions during the 

reconstruction in ZBrush. The jaw adductors include the temporalis, masseter and medial pterygoid 

muscles. The orange color represents the muscle origins for each respective muscle group. The teal 

color represents the muscle insertion for each respective muscle group (fig 14). 

Figure 14. Muscle maps of muscle origins (seen in orange) and muscle insertions (seen in teal) (A) temporalis muscle (B) 
masseter muscle (C) medial pterygoid muscle.  
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3.2 Muscle Volume Estimates 

Dr. Perry, of theCenter for Functional Anatomy and Evolution at Johns Hopkins University 

provided volume estimates of the three muscles of mastication. The resulting volumes are listed 

below (table 1). 

Table 1. Table listing the jaw adductor muscle estimates in centimeters cubed. 

4. Virtual Muscle Reconstruction in ZBrush 

 The muscles were created in ZBrush using the MaskPen tool to mask out the origin and 

insertion of each of the three muscle groups (Control + Drag Mouse). The mask was then extracted 

using Extract (Subtool > Extract > Smt 5 > Thick 0.05 > Extract). By extracting the origins and 

insertions they fit perfectly against the bone with no overlapping polygons. The muscles were then 

manipulated with the MoveTopological tool to create volume. Throughout the process the volume 

for all three muscles were checked using Check Mesh Volume in the 3D Print Hub in ZBrush 

(Zplugin > 3D Print Hub > Check Mesh Volume) (fig 15). Because ZBrush uses millimeters for its 

calculation, and the mesh and the model had previously been scaled to cm, the mesh volume results 

needed to be converted from mm3 to cm3. Once the muscles were in the correct orientation, they were 

checked by Dr. Perry to confirm their accuracy.

Figure 15. ZBrush 3D Print Hub interface (A) Check Mesh Volume location (B) Size of Mesh Volume in cubic mm.

A

B
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The muscle fibers and directions were sculpted using the Damien Standard brush. This 

allows finer details of creases, muscle fibers and tendons. Reference photos from the extant dissection 

were used while sculpting the muscles. Using the Spotlight feature the dissection photo can be 

projected as a transparent image. The fibers were sculpted in the same orientation to ensure accuracy. 

Each muscle was painted using the PolyPaint feature. The muscles were all duplicated and mirrored 

to the opposite side of the skull.   

Dr. Perry confirmed the accuracy of the muscles’ placement, volumes and muscle fiber 

orientation. After the muscles were confirmed to be in the accurate position each muscle was 

subtracted from the cranium and mandible using the Live Boolean feature. Each muscle was set to 

starting subtool and the cranium or mandible were set to intersection. This allowed for the muscles 

to fit perfectly to the mesh of the cranium without any overlap. After using Make Boolean Mesh, 

each muscle was appended as a subtool with the new subtracted bony landmarks of the origin and 

insertions. Each muscle volume was checked again using the 3D Print Hub and adjusted if needed and 

checked until correct. 

5. Creating Low Poly Models in ZBrush 

The use of high polygon models creates more data to store in a finished application. This 

can result in a heavier model causing slower loading time. To reduce a high poly model to a low poly 

model, while maintaining polypaint details, the model must be projected onto a re-meshed model. 

Decimation Master allows the reduction of polygons while maintaining the details of the original 

model. The model’s resolution can be lost when using a lower percentage of decimation (1-30%). A 

higher decimation percentage will allow for polygon reduction but preserve the details of the model 

(40-100%).  

To be able to export from Zbrush and import into Unity the model needed to have a low poly 

model. To do this the finished cranium, mandible and all of the subtool muscles were duplicated and 

then decimated by using Decimation Master (Zplugin > Decimation Master > Pre-process All 

> Decimate All). Setting the percentage of decimation between 40-100% ensured the data of the 

reconstruction were left intact (fig 16). Decimation reduces the polygons but can create a mesh that 

can be difficult to unwrap during export. The models were retopologized using ZRemesher (Tool > 

Geometry > ZRemesher) resulting in a cleaner mesh. The default settings were used on all models 

when using the ZRemesher.  
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Figure 16. ZBrush Decimation Master interface. Pre-process current circled first. Decimate Current circled second.

5.1 Projecting Textures and Polypaint onto Remeshed Low Poly Subtool 

To maintain polypaint and textural information, the high poly subtool was projected onto 

the remeshed low poly subtool. The high poly subtool was above the low poly subtool in the subtools 

list. With both subtools visible, the polypaint was projected using ProjectAll (Tool > Subtool > 

ProjectAll). The result was a low poly subtool with the same details as the high poly subtool. This 

allows for easier exporting in the following steps. 

 5.2 Creating UV Maps in ZBrush 

After projecting, the polypaint the model was subdivided (Command + D, or Tool > 

Geometry > Divide). Around 4 subdivisions were created depending on the original detail of the 

subtool. The lowest subdivision was selected to create the UV Map using UV Master (Zplugin > 

UV Master > Unwrap). To check the UV mesh UV Map was selected then Morph UV. For some of 

the more complex meshes, some areas were protected during the UV Master function. By enabling 

protection paint, important areas of detail can be avoided when unwrapping the mesh (ZPlugin>UV 

Master > Enable Control Painting > Protect (red) and Attract (Blue). The model was then 

unwrapped to check the 2D UV map (ZPlugin > UV Master > Unwrap).  
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 5.3 Exporting ZBrush Models for Unity and Blender Using Multi Map Exporter 

 After creating the UV Map, a Texture Map, Displacement Map and Normal Map are all 

created during export. A Texture Map of the polypaint was created first (Tool > Texture Map > 

Create > New From Polypaint). This creates a 2D Map of the polypainted model. The Normal and 

Displacement maps are exported for Unity using the MultiMapExporter. The MultiMapExporter is 

designed to automate the exporting process and map creation (ZPlugin > MultiMapExporter) (fig 17). 

The maps are selected for export as well as Ambient Occlusion and the .obj. By pressing Create All 

Maps, the models can be saved into the Unity project Assets for easy packaging and import. 

Figure 17. Creating Maps for Export using MultiMap Exporter. 

 6. Creating an iOS Application Using Unity 

The iOS application was created using Unity 3D software accompanied by ARFoundation 

and ARKit for the AR portion of the application. 

6.1 Wireframes 

Wireframes were created using Adobe Illustrator to plan the application interface and make 

reusing assets possible. Once the user interface was designed it was copy and pasted onto each of the 

artboards or screens of the application. Using the flowchart previously created, each wireframe went 

through every section of the flowchart and future application. The application features home screen 

with a menu containing an anatomy section, CT data section, distribution section and an animation 

section. In the anatomy section, it was important to use a simple interface that will allow users to 

easily turn on and off each layer of muscles. The distribution section contains a map with living 
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platyrrhine ranges as well as the GPS locations of the discovery sites of Homunculus patagonicus 

fossils. The animation section contains a placeholder turntable animation of that will eventually 

display the chewing biomechanics. 

6.2 Creation of User Interface in Unity 

To create the user interface (UI), the scene was toggled into 2D view to resemble an iPad 

application background. To create the background, a Quad 3D shape was added into the Hierarchy 

(Create > 3D Object > Quad). Since the Collider wasn’t needed, it was safely removed by clicking 

the 3 dots menu and clicking Remove Component. The background was created in Adobe Illustrator 

and saved as a .png in the asset folder of the Unity project. It was then projected on to the Quad shape. 

To do this, the background image was clicked and resized by using Filter Mode: Point (no filter). 

The compression was also set to None, so scaling didn’t occur. Once adjusted, the background image 

could be dragged onto the Quad. The Quad was renamed to Background for organizational purposes. 

The background image was adjusted by the shader to achieve the intended appearance (Shader > 

Sprites > Diffuse).  

Clicking on the Game view allows the image to be viewed as if it were on an iPad screen. 

To make sure the aspect ratio was correct, the Free Aspect Ratio drop down was selected and 

iPadPro Landscape option was selected because the application testing was done on an iPadPro. The 

background image was adjusted using Scale in the Transform Inspector view until it fit in the Game 

View the way it was designed.  

Back in the Scene view, a Button was added which automatically added a Canvas and 

EventSystem (Create > UI > Button). This canvas mimics the layout of an iPad screen. In this 

canvas, menu buttons were added to navigate the application. By clicking on the first button created, 

the label was renamed to the first section “anatomy.” The color was changed using the color selection 

and turning the transparency to 0% so there were no bounding boxes around the text. This was 

repeated for all three buttons: anatomy, geography, and visuals. By clicking the carrot to expand the 

layers on each button, the text that is being projected on to the canvas can be edited. Each button’s 

text was edited for its respective name.  

The title and buttons were oriented in space by highlighting both the button and the text, then 

moved with the mouse. Using the previously created wireframes, the layout was created using similar 

positions. The Game View was checked throughout this process to make sure buttons and text were 
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where they were intended to be.  

6.2.1 Coding Buttons for Scene Changes in Unity 

To make the buttons functional, a C# code needed to be created to direct the button click to 

the appropriate scene change. The function of this script allows for the scene change. First an Empty 

Game Object was added to the Hierarchy; this houses the script for the multiple buttons in the home 

screen scene (GameObject > Create Empty). The name of the Empty Game Object was changed 

to “_Manager” for organizational and managing purposes of the game. Next while the _Manager 

object was selected, a component was added by clicking Add Component and adding a new C# script 

and naming it “ChangeScene” (Add Component > New Script > Name Script > Create and Add). 

By double clicking on the “ChangeScene” Script box, the C# code opens and can be edited (fig 18). 

During this project, C# was edited using Visual Studio Code and XCode. The “ChangeScene” script 

can be found in Appendix A. 

Figure 18. Inspector view of “ChangeScene” script, double clicked to open Visual Studio Code. 

The code uses an integer to change the scene instead of using string function. Because 

multiple buttons were being coded, using an integer allowed the same script to be used multiple times 

without having to edit the script in Visual Studio. Next the anatomy button was selected from the 

hierarchy to add an On Click function by clicking the + button. The _Manager script was referenced 

by dragging and dropping it into the Name (Object) box. Next, the No Function drop down box was 

selected and given a ChangeToScene function (No Function > ChangeScene > ChangeToScene 
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(int)). Once selected, the option to add an integer appears. Each Scene in the project has an integer 

assigned to it by adding the scene to the Build (File > Build Settings (Command + Shift +B) > 

Scenes in Build > Drag and drop scenes into Scenes in Build box). Once a scene in dropped 

into the Scenes in Build box, the integer appears on the right-hand side (fig 19). The integer can be 

adjusted by dragging and dropping the order of the scenes. The home screen (Scene 01) had an integer 

of 0 and the anatomy scene had an integer of 1. A scene was created for each of the menu buttons and 

added to the Build Settings. The respective integer was edited based on where the button was taking 

the user. This was repeated for every scene. 

Figure 19. (A) OnClick changed from No Function to ChangeToScene (B) Integer section set to 1 to create button for 
anatomy scene (C) Build Settings window showing Scenes in Build list with integer on right hand side. 
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6.3 Creation of Home Scene in Unity 

The home scene was created by implementing the buttons and UI from the previous steps. 

This scene also included an information button that opens a panel with external URL links. Two 

buttons were created for each URL, one for more information on Homunculus patagonicus and a 

second leading to sandersmedicalmedia.com. After the two buttons were created, a C# script was 

created and dragged onto both buttons. As seen in Appendix C, a “urlOpener” Script was created 

in Visual Studio. In the On Click section of the button, a function was added, and the button was 

dragged into the function. It was then set to url.Opener.Open which allows the button to open an 

external website (fig 20A). The URL is set, but below that in the URL Opener (Script) box (fig 20B). 

This was done for both buttons and their respective website URLs. 

Figure 20. (A) The URL button was dragged into the On Click box and set to urlOpener.Open (B) the URL box was set to 
the portfolio website. 

6.4 Creation of Anatomy Scene in Unity including 3D Model 

The anatomy section of the application incorporates the 3D models and muscles of 

mastication using toggles, in addition to a Lean Touch and Camera Pivot. The models were 

imported into a folder in the “Assets” folder. Each .obj was dragged into the Hierarchy and then right 

clicked to Unpack the Prefab. The polypaint material UV map was dragged onto each respective 

object if it wasn’t already associated with the .obj. This was repeated for every .obj that was exported 

from ZBrush. 

6.4.1 Creation of Toggles 

Toggles were created in the anatomy scene of the application as well as in the geography and 

taxonomy scene. A toggle talks to a specific GameObject in a scene and adjusts a certain property 
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of that GameObject. The purpose of multiple Toggles in the anatomy section was to change the 

visibility of the muscles on the 3D model. There was also a toggle to turn off all the muscles to view 

the origins and insertions of the muscles on the cranium and mandible. Finally, a toggle was created 

to turn all the muscles on with labels and a second toggle to turn all the origins and insertions with 

labels on.  

First a toggle was added to the canvas in the hierarchy (GameObject > UI > Toggle). The 

Toggle comes with three elements: the toggle itself, the background of the toggle and a checkmark. 

When selected on the toggle, the Inspector contains an On Value Changed (Boolean) List. This will 

list all the objects that the toggle can talk to when the Checkmark is checked on or off. To set up the 

Temporalis Muscle toggle, the temporalis muscle GameObject was dragged into the empty slot (fig 

21A). The function was set by clicking No Function drop down menu and creating the SetActive (No 

Function > GameObject > SetActive). A function was added by clicking the + at the bottom of the 

On Value Changed (Boolean) list. The same temporalis muscle GameObject was dragged into the 

new function. This time, a different SetActive function was selected (No Function > GameObject > 

Set Active). This function should not have a box next the GameObject (fig 21B). This was repeated 

for all the toggles in the application.  

Figure 21. (A) The Temporalis Muscle GameObject was dragged into the On Value Changed box to talk to the Toggle UI 
Component. (B) Second SetActive function. 

6.4.2 Adding Design Elements to Toggles 

The default toggle was customized using the elements created in Adobe Illustrator when 

creating the wireframes. The designed aesthetic was achieved by opening the carrot of the toggle, 

selecting the Background layer, and manipulating the Image section. To remove the box that the 

checkmark sits in front of, the Color Picker was selected and the A section was set to 0, representing 
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0% opacity. The Checkmark layer was then selected and a custom 2D sprite was added into the 

Source Image box. The text of the Toggle was changed and manipulated on the Canvas until the 

desired look was achieved. This was repeated for all of the toggles in the application. 

6.4.3 Creation of Touch Rotation using CameraPivot 

The rotation of the object was created using a CameraPivot provided by Sam Bond. This 

allows the camera to rotate around an object after setting the Target to the 3D Models. When 

selected on the CameraPivot in the Hierarchy, both scripts were checked off, Lean Pitch Yaw 

Smooth (Script) and Lean Multi Set (Script). To ensure that all of the 3D models that were 

previously imported had the same center of pivot, they were all dragged into an EmptyObject 

(GameObject > CreateEmpty). This EmptyObject was renamed to “3D Models Container”. A 

second EmptyObject was created and the 3D Models Container was dragged into it. This was 

renamed to “Muscles Anchor”. Making sure the Toggle Tool Handel Position was set to Pivot and 

the Toggle Tool Handel Rotation was set to Local, all the 3D models were aligned at the center. 

A C# script was added to the Muscles Anchor Empty Object called “RotateObjectOnTouch” 

(Appendix B). This allows the objects to rotate when a user is touching the screen of an iOS device.  

6.4.4 Creating Augmented Reality Using AR Foundation in Unity 

 AR Foundation is a package enables the creation of augmented reality (AR) applications 

in Unity. It uses Computer Vision technology to recognize 3D objects in real time. AR Foundation 

also omits the use of an image tracker which will be helpful for field researchers especially when 

using this portion of the application to compare to specimens they are uncovering to Homunculus 

patagonicus in real time. In addition, this application can be used by researchers visiting museums to 

compare fossils in those collections to this model.

 After installing the AR Foundation and ARKit needed for iOS development (from the 

package manager in Unity), a new scene was created to house the AR functionality. First an AR 

Session is added to the hierarchy (GameObject > XR > AR Session). The AR Session isn’t directly 

interacted with, but it allows the necessary set up for the scene to work as an AR scene. Next, an AR 

Session Origin object is added to the hierarchy (GameObject > XR > AR Session Origin). The 

AR Session Origin object is important to initialize the surrounding physical world and manipulate 

the scale of the object a user is playing with in real time. The AR Session Origin contains an AR 

Camera, so the Main Camera that was created with the scene was deleted. The AR Camera was 
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selected and Tagged as “Main Camera” in the AR Camera’s inspector. 

Next the reconstructed fossil .OBJ file was added to the hierarchy. The .OBJ needed to be 

scaled down because it was too large for the scene. In Unity, one unit is equal to 1 meter in the real 

world. The model was scaled to .1 in the X, Y, and Z scale boxes. The object was raised 0.05 on the Y 

axis to allow it to sit above the ground plane in Unity. The application was tested using Xcode during 

the building process (See Deploying the Application using XCode).  

The skull needed to be positioned so that it appeared to be sitting on a surface in the AR 

world. Instead of placing the skull as a fixed position in the scene, it was placed dynamically. Before 

turning the skull into a Prefab, the center of the cranium needed to be set at the base of the object. To 

do this an Empty GameObject was created (GameObject > Create Empty). The skull was dragged 

into the empty object to become a child with the correct registration position. To create a Prefab of 

the cranium, the empty object was dragged into the Asset folder of the Unity Project. The skull was 

then deleted and was added to the scene later.  

A placement indicator was created next to allow the user to place the cranium object into 

the AR world. This was done by creating an Empty GameObject (GameObject > Create Empty). 

Within that object a quad is added as a child (GameObject > 3D Object > Quad). This simple flat 

plane is parallel with the floor when running the application. The quad was scaled down to the same 

proportion of the cranium object. A texture was imported to use on the quad. Once imported into the 

project, the alpha channel of the texture was set to Alpha is Transparency. A material was created 

where the previously created texture can be used (Right Click in Assets > Create > Material). With 

the material selected, the Shader was set to Unlit > Transparent. The texture was then selected in the 

Inspector window of the material. This material was then dragged on to the quad, creating the visual 

indicator for the AR scene.  

A script was then created to control the logic in the AR scene (Right Click in Assets > 

Create > C# Script). This script can be referenced in the Appendix D: “ARTapToPlaceObject” 

Script. Once this script has been added to an Empty Object, the script allows an Object To Place 

as well as a Placement Indicator function. In the Object to Place function the cranium prefab was 

dragged. In the Placement Indicator function the placement indicator material previously created 

was added. This script allows the user to click on the screen and place the cranium on a flat plane, 

avoiding the need for a printed image recognition while in the field.  
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To create the illusion of a shadow for the AR scene, a shadow texture was applied to a quad 

in a similar manner as the placement indicator. This shadow rotates with the object, mimicking an 

actual shadow appearance of the cranium object. This quad is dragged into the cranium prefab and 

acts as a child. This allows rotation on touch. The scene also allows the user to click back using the 

360-degree button which changes the scene back to the anatomy portion of the application. 

6.5 Creation of CT Data Scene in Unity  

The CT data section of the application includes the original CT data of MPM-PV 17453 as 

well as the second data set, MPM-PV 3502, from which the orbits, nasal bone and zygomatic arch 

were used for the reconstruction. Both .OBJ files were decimated in ZBrush before importing them 

into the project to reduce the size of the file. This scene utilizes toggles to turn on and off the two 

specimens. It also includes the rotational script from Appendix B. 

6.6 Creation of Distribution Scene in Unity 

The distribution scene contains similar toggles to those made in the anatomy scene. The 

toggles impact the visibility of living platyrrhine distribution ranges. All the family’s ranges can be 

check-marked on at once or isolated to a few and even one single range. Two buttons were created 

to make “folder tabs” at the top of the text box. The first button “Platyrrhini Ranges” controls the 

visibility of the toggles of the family ranges and a phylogenetic tree. The second button Homunculus 

patagonicus GPS controls the visibility of information on Homunculus patagonicus. This section 

also zooms into the GPS coordinates where the specimens used in this project were collected. Both 

buttons turn off the opposite buttons’ contents. 

To create the first button, all the contents of the Platyrrhini Ranges were dragged into an 

EmptyObject. This allowed easy organization, especially when controlling the state of the object’s 

visibility using the button click. A Button was created, and the carrot was opened to select the 

Text layer and edited to read Platyrrhini Ranges (GameObject > UI > Button). Selecting back 

on the Button, layer components were added to the On Click list using the +. Like the Toggles, 

a GameObject was dragged into the box and the GameObject was SetActive (No. Function > 

GameObjects > SetActive(bool). The checkmark directly under the GameObject.SetActive list 

was checked on to ensure this button turns that object on when clicked. To hide the Homunculus 

patagonicus GPS button’s contents, another function was added with the + to the On Click list. The 

EmptyObject with the Homunculus patagonicus GPS contents was dragged into the box and Set to 
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Active. This time, the box below the GameObject. SetActive was left unchecked. This will ensure 

that when this button is clicked, the opposite button’s contents will turn off visibility. This workflow 

was repeated for the second button. 

6.7 Creation of 3D Animation and Implementation in Unity 

A low-fidelity turntable animation was created that will be replaced by an animation of the 

chewing biomechanics of the Homunculus patagonicus specimen. 

6.7.1 Creation of Video Player in Unity 

The animation was housed in a video player that was created by starting with an Empty 

Object (GameObject > Empty Object). A second empty object was created as a child in the first 

empty object. The child was then selected, and inside of the Inspector, a Video Player component 

was added (Add Component > Video Player). The animation was then dragged and dropped into the 

Video Clip component in the inspector.  

7. Deploying the Application using Xcode 

After the entire Unity project was completed, it was time to build the application to be 

deployed to an iOS device. This was done by selecting Build from the Build Settings (File > Build 

Settings > iOS > Build). The build was saved into a folder called “Builds” in the project folder, and 

saved. Once the build was saved, an Xcode file was saved in the folder. This was opened using Xcode. 

There were some settings that needed to be adjusted in Xcode to allow the application to 

run on an iOS device. With the project navigator selected, the top Unity-iPhone node was selected 

(figure 22). This displayed a list of general project settings. A provisioning profile was required for 

building the project. If automatic signing is turned off, this this needs to be selected manually. When 

launching to the Apple App store, a Developers account needs to be created. For general testing, a 

personal account was used (figure 23). 

Figure 22. Screen shot of project navigator selected, as well as the Unity-iPhone node selected. 
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Figure 23. Screen shot Signing & Capabilities with the Personal Team selected from the Team dropdown menu. 

Once the settings were selected, the device the application was to be deployed to was selected 

and the Play button was clicked. With no errors occurring, this deployed the application to the 

selected device. Specifically for the AR portion of the application, the app asked permission to use the 

device’s camera. To stop the application testing, the Stop button in Xcode is clicked.



33

Results

1. Fossil Reconstruction Results 

The digital fossil reconstruction of Homunculus patagonicus occurred in multiple stages which al-

lowed the specimen to be viewed for the first time as an average, composite member of the species. 

The first stage resulted in manual sediment removal followed by the reorientation and alignment of 

fragments to make the specimen as anatomically correct as possible. The second stage resulted in a 

digital restoration that filled in the missing anatomy and fragments. The third stage resulted in a fully 

reconstructed digital model of Homunculus patagonicus with as many data preserved as possible to 

showcase details of the bony landmarks and muscle attachment sites. The stages are represented in 

Figures 24-29 
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2. Muscle Reconstruction Results 

The muscles of mastication of Homunculus patagonicus were reconstructed digitally with numerical 

data. The volumetric data of the muscles were calculated by evaluating the extant muscles from 

multiple dissections. The calculations resulted in volumetric estimates for the masseter, medial 

pterygoid and temporalis muscles (table 2). The volumetric data were then used to create digital 

muscle models that attached to the cranium and mandible of the reconstructed fossil (figs 30-33). The 

muscles were constructed using their origin and insertion sites. The origin and insertion for each 

muscle group are seen in the following figures (fig 34).  

Table 2. Table listing the jaw adductor muscle estimates in centimeters cubed. Note that the original estimate of 0.6 was an 
underestimate made clear once the muscle was reconstructed. The alternate estimate of 1.3 was deemed more realistic and 

used in the final reconstruction. 
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3. 3D iOS Application Results 

A fully interactive iOS application was created featuring the 3D reconstructed models, original CT 

data, distribution maps of extant primates, a lineage map, fossil distribution, a placeholder animation, 

and an augmented reality aspect (figs 35-43). 
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4. Workflow Results 

Flow chart documenting the workflow between multiple programs during the project. 

Figure 44. Diagram of project workflow. 
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5. Asset Referral Information 

Assets can be found at 

sandersmedicalmedia.com and 

The Department of Art as Applied to Medicine 

at the Johns Hopkins University 

Baltimore, MD. 
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Discussion

The goal of this project was to reconstruct, for the first time, the missing anatomy of a  

complete fossil specimen of Homunculus patagonicus to provide a publicly accessible resource for 

researchers, students and the interested public to view and learn about the specimen. This section 

discusses what was involved in each section of reconstruction and development of assets, including 

the 3D models, interactive iOS application, and animation turntable, as well as any limitations that 

were encountered.  

1. Fossil Reconstruction 

The main goal for the digital reconstruction was to provide a complete Homunculus 

patagonicus cranial specimen, free of any fragmentation, distortion, or missing anatomy. This 

allows researchers, for the first time, the ability to make accurate osteological measurements using 

the data of an average individual of the Homunculus patagonicus species. The CT data provided for 

this specimen however were so impacted with sediment that osteological details were impossible 

to visualize. For example, sediment in the TMJ would not allow the re-orientation of the mandible. 

The sediment created millions of polygons that would not allow the use of some functions needed 

in ZBrush to complete the reconstruction. The workaround for this issue is described in depth in the 

Materials and Methods section. 

When reconstructing the specimen, great care was taken to preserve as many data as 

possible to avoid any bias while removing sediment and adjusting fragments. It was an advantage 

to have a second Homunculus patagonicus specimen, MPM-3502, allowing any missing anatomy 

to be borrowed and merged to the MPM-17453 reconstruction. This preserved the data and the 

consideration of an average individual of the Homunculus patagonicus species. By reconstructing the 

fossil in stages, anyone using the application can study the original CT data and compare to the fully 

reconstructed model. 

2. Muscle Reconstruction 

The main goal of the muscle reconstruction was to compare and use extant models to 

recreate the jaw adductors of Homunculus patagonicus. This was done both digitally and numerically 

allowing the visualization of muscle proportion to the osteological features. While more information 

is still needed to infer a specific diet, the reconstruction did provide visual verification that the 

dimensional data were realistic for the temporalis and masseter groups. However, the medial 
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pterygoid volume estimate was originally 0.6cm3. When this volume was used, the muscle was 

so small that it could not extend between its origin and insertion. With this finding Dr. Perry used 

comparative measures to recalculate a volume that would allow for a more proportional volumetric 

relationship to the temporalis group and masseter group. This new estimate was 1.3cm3, which 

compared favorably to the data in Slade 2018 (using a similar process but for a different primate). 

The muscle models provide a visual representation of Homunculus patagonicus to allow for future 

inferences to be made on the diet with the consideration of the specimen’s heavy tooth wear. 

3. Interactive iOS Application 

The digital reconstruction created in this project, the CT data of both MPM-PV 17453 

and MPM-PV 3502, geographical distribution of extant versus fossil locations, lineage map and 

chewing animation were all incorporated into an iOS application. Once the interactive application 

is downloaded the user would not need WIFI. This is especially important if in the field conducting 

research. The reconstructed model can be rotated with or without the muscles visible, as well as 

with labels on or off. With the muscles off, the user has the ability to view the muscle origins and 

insertions or choose to leave those turned off as well to focus on the osteological details.  

When implementing the models into Unity, models needed to be optimized for performance 

in the application. This process is described in detail in the Materials and Methods section to create 

low polygon models. Once the models were implemented, the materials needed to be adjusted as 

polypaint was used in ZBrush and some of the Normal Maps for the UV Texture maps were missing. 

The workflow from ZBrush to Unity is not as popularly used with such organic and detailed models 

compared to other 3D open source software.  

The in-progress testing of the application became crucial towards the end of the project 

especially with the implementation of augmented reality. Unfortunately, with recent updates to Unity 

2019.3.1 and Vuforia 8.6, the originally planned combination of software to create the AR portion of 

the app were not functional together. The Unity project would crash upon testing using the game play 

button. Vuforia had to be completely removed from the project (all packages included) to allow the 

other sections of the app to be built out to XCode for testing on an iPad.  

The second issue that occurred with application testing was directly involved with the 13.3.1 

iOS operating system Apple had recently launched. This resulted in developers not being able to 

launch any applications through XCode onto an iPad for testing. Luckily, the Department of Art as 
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Applied to Medicine provided an iPad for testing that had not been automatically updated (unlike my 

personal iPad). After these issues were resolved, the application could move forward with user testing 

and any adjustments needed could be made before launching to the app store. It is also valuable to 

note, an iOS application was the preferred build mode due to the specific requirements Apple has for 

launching an app to the Apple Store. Once built as an iOS, the app can be eventually transitioned into 

an Android application. 

4. Reproduction of Workflow 

The workflow during this project utilized multiple programs from the beginning segmenta-

tion to the resulting iOS application. The workflow in this project was described in a way in which an 

individual with basic knowledge of the software could reproduce similar results. The detailed expla-

nations offer not only biocommunicators a guide to digital reconstruction, but anyone interested in 

facial reconstruction.  



61

Conclusion

This project generated the first ever augmented reality 3D primate fossil reconstruction iOS 

application. The main features of this project are a fossil reconstruction from CT data, jaw adduc-

tor musculature, and lineage distributions. Multiple digital processing programs resulted in a fully 

interactive and accessible application. The application combines CT imaging, 3D sculpting, interac-

tive design and user interface to inform researchers, students and the general public of this important 

anatomy. This project will allow multiple audiences access to this unique specimen’s anatomy. In 

addition, the documented workflow will provide future biocommunicators and surgeons a future 

direction for surgical planning and facial reconstruction. 
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Appendix

Appendix A: “ChangeScene” Script  

using System.Collections; 
using System.Collections.Generic; 
using UnityEngine; 

public class ChangeScene : MonoBehaviour 
{ 
public void ChangeToScene (int sceneToChangeTo) 
{ 
Application.LoadLevel(sceneToChangeTo); 
} 
} 

Appendix B: “RotateObjectOnTouch” Script 

using System.Collections; 
using System.Collections.Generic; 
using UnityEngine; 

public class RotateObjectOnTouch : MonoBehaviour 
{ 
public float sensitivity = 1; 
public float threshold = 0.2f; 

// Update is called once per frame 
void Update() 
{ 
// touch/mouse left click 
if(Input.GetMouseButton(0)) 
{ 
// get the mouse/finger movement 
float h = sensitivity * -Input.GetAxis(“Mouse X”); 
float v = sensitivity * -Input.GetAxis(“Mouse Y”); 

// check the movement threshold 
// this is not really needed but it helps make the movement less sensitive 
if(Mathf.Abs(h) < threshold) h = 0; 
if(Mathf.Abs(v) < threshold) v = 0; 

transform.Rotate(-v, h, 0, Space.World); 
} 
} 
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} 

Appendix C: “urlOpener” Script 

using System.Collections; 
using System.Collections.Generic; 
using UnityEngine; 

public class urlOpener : MonoBehaviour 
{ 

public string Url; 

public void Open() 
{ 
Application.OpenURL(Url); 
} 
} 

Appendix D: “ARTapToPlaceObject” Script 

using System.Collections; 
using System.Collections.Generic; 
using UnityEngine; 
using UnityEngine.XR.ARFoundation; 
using UnityEngine.Experimental.XR; 

public class ARTapToPlaceObject : MonoBehaviour 
{ 
public GameObject objectToPlace; 
public GameObject placementIndicator; 

private ARSessionOrigin arOrigin; 
private Pose placementPose; 
private bool placementPoseIsValid = false; 

void Start() 
{ 
arOrigin = FindObjectOfType<ARSessionOrigin>(); 
} 

void Update() 
{ 
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UpdatePlacementPose(); 
UpdatePlacementIndicator(); 

if (placementPoseIsValid && Input.touchCount > 0 && Input.GetTouch(0).phase == TouchPhase.
Began) 
{ 
PlaceObject(); 
} 
} 
private void PlaceObject() 
{ 
Instantiate(objectToPlace, placementPose.position, placementPose.rotation); 
} 

private void UpdatePlacementIndicator() 
{ 
if (placementPoseIsValid)  
{ 
placementIndicator.SetActive(true); 
placementIndicator.transform.SetPositionAndRotation(placementPose.position, placementPose.rota-
tion); 
}  
else 
{ 
placementIndicator.SetActive(false); 
} 
} 
private void UpdatePlacementPose() 
{ 
var screenCenter = Camera.current.ViewportToScreenPoint(new Vector3 (0.5f, 0.5f)); 
var hits = new List<ARRaycastHit>(); 
arOrigin.Raycast(screenCenter, hits, TrackableType.Planes); 

placementPoseIsValid = hits.Count > 0; 
if (placementPoseIsValid) 
{ 
placementPost = hits[0].pose; 

var cameraForward = Camera.current.transform.forward; 
var cameraBearing = new Vector3(cameraForward.x, 0, cameraForward.z).normalized; 
placementPose.rotation = Quaternion.LookRotation(cameraBearing); 
} 
} 
}
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